# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\")(?:[A-Z][a-f0-9]{84}|[A-F0-9]{36})(?=\")"
test_str = ("$(document).ready(function() {\n"
" vlive.tv.common.init(\"en\", \"VE\", \"5454545\");\n"
" vlive.video.init(\"VOD\", \"45454\", \"VOD_ON_AIR\", \"NONE\", \"54454F\",\n"
" \"6FABE43B271345FFCFA4D2028AF85F80C9F6\",\n"
" \"V1294005a2aac29b64592ce9e636d68fb5506721c2ceac160d67a0488c1d25f3314bace9e636d68fb5506\",\n"
" [],\n"
" \"\", \"true\", \"false\");\n"
" new vlive.video.list().init(\"suggest\", \"6\", \"/video/suggest/more\", {videoSeq:\"454545\", channelCode:\"54545\"}); new vlive.video.list().init(\"upcoming\", \"6\", \"/video/upcoming/more\", {videoSeq:\"54545\", playlistSeq:\"\", channelCode:\"5454545\"}); \n"
" vlive.tv.live.thumb.handler.init(\"https://vlive-thumb.pstatic.net\");\n"
" vlive.tv.share.init(\"Some Title\", \"https://www.vlive.tv/video/xxxx\", \"https://v-phinf.pstatic.net/20190811_131/4509495095_JPEG/93e3a15d-bc43-11e9-a12f-5054343_43.jpg?type=a720_play\", \"shareVod_343434_4455457\", \"45454\");\n"
" vlive.video.showShoppingBanner(\"4544343\");\n\n"
" });")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.