# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\da-fA-F]{8}-[\da-fA-F]{4}-[\da-fA-F]{4}-[\da-fA-F]{4}-[\da-fA-F]{12}"
test_str = ("4af06d20-10d5-4d9f-bfce-ca2724a82803\n"
"2a3e42b3-f3d44501-89ee-835164dcecd6f (-f3d44501-)\n"
"d7e3c311-b5b4-4c9f-a3df-a56b8512f60b\n"
"2193cf3f-8da8-4d8a-9103-c91cca66889c\n"
"80112dcf-bec8-428d-8f0-b4fd0ca506d5c (-8f0-)\n"
"{a8fbdb9f-56ac-44c9-a74f-21b393e57e57}\n"
"51b16c80-901c-4270-93a7-120a8cGb42ab (\"G\")\n"
"e257613b-ca10-412e-aeaf-0597db11162c\n"
"4ed178df-7575-457f-aef1-03b44b68e55H (\"H\")\n"
"a5E5108-5e54-4-28-b406-83a2-9a711bc4 (-4-28-)\n\n"
"Power Scheme GUID: 0f916538-c8d5-4144-be2a-ee82eccf6413 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.