re = /(?<=\bSalutation:.*\sx\s.*)\bM(?:rs?|x)\./m
str = 'Salutation: Mr. x Mx. Mrs.
Salutation: Mr. Mx. x Mrs.
Salutation: Mr. Mx. x Mr.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end