re = /(jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)(?:-(?1))?/m
str = 'jan
jan-mar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end