// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)^
# Build information should not contain dev and nightly stuff:
(?!.*(nig(ht|th)ly|develop|development))
# Optional compatibility prefix "version-" or "v":
(?<compatibility>[a-z]*-|v)?
# Major, minor and patch numbers:
(?<major>\d+)\.(?<minor>\d+)\.(?<patch>\d+)
# Capture the optional build information:
(?:
[\.-]?
(?<build>.*)
)?
$"#).unwrap();
let string = "100.200.300
100.200.300.7068-ls170
v100.200.300-ls213
version-100.200.300
version-100.200.300-ls180
version-100.200.300.11111
100.200.300.7068-ls170
nigthly-100.200.300
nightly-100.200.300.3604-ls587
100.200.300-development
100.200.300-develop
100.200.300-nigthly
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}