package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)SELECT(.+)FROM`)
var str = `select nome, sobrenome from table`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}