package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^text$|text | text)`)
var str = ` text .text. 'text'
text .text. 'text'
text
text
text
edittext
textedit`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}