$re = '/\/start\s(\d+)?/m';
$str = '/start
/start 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);