// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:(?:"\s*[:,]|\{)\s*"|\\"|"\s*[:}])"#).unwrap();
let string = "{\"key\":\"val\"ue\",\"other\":\"invalid \"\"quo\"te\"}
{\"key\":\"val\"ue\",\"other\":\"invalid \"\"quo\"te\",\"hello\":{\"world\":\"hell\"o\"}}
{\"key\":\"va\\\"l\"ue\",\"other\":\"invalid \"\"quo\"te\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}