package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)S{2,}`)
var str = `S
SS
SSS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}