const regex = /[\w\x{0021}-\x{003F}]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\\x{0021}-\\x{003F}]+', 'gu')
const str = `एकa1!a?23!sd2अ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}