re = /(?:\G(?!^)(?(?=\d+(?:EXE_IN\.preparing|bbb\.xxx))(?<!\dccc\.xxx))|(?=(?:\d+(?:EXE_IN\.preparing|bbb\.xxx))+(?:\d+ccc\.xxx)+))(\d+)(EXE_IN\.preparing|bbb\.xxx|ccc\.xxx)/m
str = '1EXE_IN.preparing2EXE_IN.preparing3EXE_IN.preparing4EXE_IN.preparing5EXE_IN.preparing6EXE_IN.preparing7bbb.xxx8ccc.xxx9ccc.xxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end