$re = '/<([^>]*)>((?:True,)*True|False)/m';
$str = '<string>True,True,True,True,True,True,False,False,False,False,False,False,False,False,False,False,False,False,False,False</string>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);