import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\}\\{]*?\"content\"\\s*:[^\\}\\{,]*?imgur\\.com[^\\}\\{,]*?,[^\\}\\{]*?\"from\"\\s*:[^\\}\\{,]*?ken_8520[^\\}\\{,]*?,[^\\}\\{]*?\\}";
final String string = "{\"id\": \"1508640338717\",\n"
+ "\"displayName\": null,\n"
+ "\"originalarrivaltime\": \"2017-10-25T14:08:57.128Z\",\n"
+ "\"messagetype\": \"RichText\",\n"
+ "\"version\": 1508640338717,\n"
+ "\"content\": \"<a href=\\\"https://i.imgur.com/RTzSZiY.jpeg\\\">https://i.imgur.com/RTzSZiY.jpeg</a><e_m ts=\\\"1508940494\\\" ts_ms=\\\"1508940494784\\\" a=\\\"live:ken_8520\\\" t=\\\"61\\\"/>\",\n"
+ "\"conversationid\": \"8:markv\",\n"
+ "\"from\": \"8:live:ken_8520\",\n"
+ "\"properties\": null,\n"
+ "\"amsreferences\": null},\n\n"
+ "{\"id\": \"1508454757179\",\n"
+ "\"displayName\": null,\n"
+ "\"originalarrivaltime\": \"2017-10-23T10:29:14.857Z\",\n"
+ "\"messagetype\": \"RichText\",\n"
+ "\"version\": 1508454757179,\n"
+ "\"content\": \"<a href=\\\"https://i.imgur.com/hhSOfJu.jpeg\\\">https://i.imgur.com/hhSOfJu.jpeg</a><e_m ts=\\\"1508754504\\\" ts_ms=\\\"1508754504997\\\" a=\\\"live:ken_8520\\\" t=\\\"61\\\"/>\",\n"
+ "\"conversationid\": \"8:markv\",\n"
+ "\"from\": \"8:live:ken_8520\",\n"
+ "\"properties\": null,\n"
+ "\"amsreferences\": null},\n\n"
+ "{\"id\": \"1508405154918\",\n"
+ "\"displayName\": null,\n"
+ "\"originalarrivaltime\": \"2017-10-14T18:19:13.66Z\",\n"
+ "\"messagetype\": \"RichText\",\n"
+ "\"version\": 1508405154918,\n"
+ "\"content\": \"<a href=\\\"https://i.imgur.com/u1QFzVu.gif\\\">https://i.imgur.com/u1QFzVu.gif</a>\",\n"
+ "\"conversationid\": \"8:markv\",\n"
+ "\"from\": \"8:live:ken_8520\",\n"
+ "\"properties\": null,\n"
+ "\"amsreferences\": null},\n\n"
+ "{\"id\": \"1515194882829\",\n"
+ "\"displayName\": null,\n"
+ "\"originalarrivaltime\": \"2018-01-05T20:41:19.069Z\",\n"
+ "\"messagetype\": \"RichText\",\n"
+ "\"version\": 1515194882829,\n"
+ "\"content\": \"<a href=\\\"https://i.imgur.com/IxcxW.gif\\\">https://i.imgur.com/IxcxW.gif</a>\",\n"
+ "\"conversationid\": \"8:markv\",\n"
+ "\"from\": \"8:live:ken_8520\",\n"
+ "\"properties\": {\n"
+ " \"urlpreviews\": \"[{\\\"key\\\":\\\"https://i.imgur.com/IxcxW.gif\\\",\\\"value\\\":{\\\"url\\\":\\\"https://i.imgur.com/IxcxW.gif\\\",\\\"size\\\":\\\"499834\\\",\\\"status_code\\\":\\\"200\\\",\\\"content_type\\\":\\\"image/gif\\\",\\\"site\\\":\\\"i.imgur.com\\\",\\\"category\\\":\\\"generic\\\",\\\"favicon\\\":\\\"https://neu1-urlp.secure.skypeassets.com/static/imgur-16x16.ico\\\",\\\"favicon_meta\\\":{\\\"width\\\":16,\\\"height\\\":16},\\\"thumbnail\\\":\\\"https://neu1-urlp.secure.skypeassets.com/img1/48c8cb02-cbff-4f3a-b7da-2c140a8d1b24.gif\\\",\\\"thumbnail_meta\\\":{\\\"width\\\":216,\\\"height\\\":207},\\\"user_pic\\\":\\\"\\\"}}]\"\n"
+ "},\n"
+ "\"amsreferences\": null}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}