$re = '/(\d+)(?!.*\b\1\b)/';
$str = '[[8,9,7],[7,8,9,33,21],[11,12,33,21,9,31]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);