$re = '/(.*?)\<(.*?)\>(.*?)|\z/';
$str = 'blablablabla <email1@domain.com>; blablablabla <email2@domain.com>; blablablabla <email3@domain.com>; blablablabla <email4@domain.com>; blablablabla <email5@domain.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);