$re = '/([A-Z])(.*?);/m';
$str = '10A123;B-456;C0; D45;EWTF; F-999.0;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);