import re
regex = re.compile(r"((?:[01]?[0-9]?[0-9]|2[0-4][0-9]|25[0-5])(?:\.(?:[01]?[0-9]?[0-9]|2[0-4][0-9]|25[0-5])){3})(?!\S).+?(?<!\S)((?:[01]?[0-9]?[0-9]|2[0-4][0-9]|25[0-5])(?:\.(?:[01]?[0-9]?[0-9]|2[0-4][0-9]|25[0-5])){3})")
test_str = ("Gateway of last resort is 10.119.254.240 to network 10.140.0.0 \n"
"O E2 10.110.0.0 [160/5] via 10.119.254.6, 0:01:00, Ethernet2\n"
"D 10.67.10.0 [200/128] via 10.119.254.244, 0:02:22, Ethernet2\n"
"O E2 10.68.132.0 [160/5] via 10.119.254.6, 0:00:59, Ethernet2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")