$re = '/[^\/]*(?=\.html)/m';
$str = 'https://www.sample.com/avantco-178gskt19824-door-gasket-for-gdc-12f-and-gdc-12f-hc-merchandiser-freezers/178GSKT19824.html?utm_source=google&utm_medium=cpc&utm_campaign=GoogleShopping';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);