import re
regex = re.compile(r"(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\u0020-\u002f\u003A-\u0040\u005B-\u0060\u007B-\u007E]).{8,}", flags=re.MULTILINE | re.UNICODE)
test_str = ("jhiuyJSY27\n"
"HU7987BVF6\n"
"HB5rrf67\n"
"GH5+m09b\n"
"jfi-09uyT\n"
"ok8^87VF\n"
"09POlo\n"
"09nbf4-DE\n"
"IGORMARIO\n"
"ndjh765b\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")