package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{1,3}(?:\.\d{3})*,\d+\b`)
var str = `R$ 2.199,99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}