re = /(?<=^c[^"']*['"][^"']*)\b\w+/m
str = 'c"word & word" = word + word
c"12 = word" + word + "qq"
c word & word = word + word
c 12 = word + word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end