const regex = new RegExp('(?i)^Invoice[\\p{Zs}\\t]+Nr\\.?\\s*(?<arvenumber>[^\\W_]+)[\\s_]', 'gm')
const str = `...
Some nr_11687767_ other 101308591
Invoice Nr.
M230714_some text
Kirjeldus
...
Sometimes it is terminated by newline
...
This nr_11687767_KMKR_EE101308591
Invoice Nr.
M230714
01.05.2023
Item
...
or by other white space delimiter :
...
Some nr_11687767_ Text
Invoice Nr M230714 Date 01.05.2023
Desc
...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}