$re = '/Agent (\w)\w*/m';
$str = 'Agent Alice gave the secret documents to Agent Bob';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);