re = /^.*?[ ]+.*?[ ]+(.*?)[ ]/m
str = 'Windows SERVERMAIN 10.0.14393 Microsoft Windows Server 2016 Standard x64'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end