re = /^(19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])$/m
str = '1900-01-01
1900/01/01
1900-01/01
1900/01-01
1899/12/31
2099/01/01
2100/01/01
2099 12 31
2099/12/31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end