$re = '/(^[0-9]{1,2}\.?[0-9]?\+?$)/m';
$str = '2.5+
2.5
2+
2
2..5
+2.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);