const regex = new RegExp('<div class="popup-container modal-expiration-message-link">.+?</div>\\s+(?=</li>)', 's')
const str = `<li>
Срок действия:<div id="expiration-message-link" class="question-mark popup-modal popup-expiration-message-link">?</div> марта 2021
<div class="popup-container modal-expiration-message-link">
<div class="popup-title">
Срок действия
</div>
<div class="popup-content">
<p>Продолжительность срока действия или "лучше использовать до указанной даты" зависят от типа продукции и бренда.</p>
<p>Скоропортящиеся продукты (такие, как масло льна или некоторые пробиотики) обычно имеют более короткие сроки годности. Несмотря на то, что наш склад полностью оснащен оборудованием для кондиционирования воздуха, наиболее скоропортящиеся товары хранятся в холодильнике (морозильной камере или холодильном помещении) для сохранения максимальной свежести.</p>
<p>Принимающий отдел компании делает все возможное, чтобы убедиться в корректности сроков годности для всех поступающих продуктов и ввести их в систему. Однако, иногда возможны расхождения. Как уже было сказано, исключительно быстрый оборот продукции в iHerb гарантирует, что наши запасы товаров являются одними из самых свежих в отрасли.</p>
</div>
</div>
</li>
<li>
Вес Отправления:<div id="shipping-weight-link" class="question-mark popup-shipping-weight">?</div>
<div class="dimensions-popup-wrapper weight">
<span class="product-weight">
0.21 кг
</span>
<div class="dimensions-units-popup weight">Переключиться на империальные единицы</div>
</div>
<div class="popup-container modal-shipping-weight">
<div class="popup-title">Вес Отправления</div>
</div>
</li>
<li>Код Товара: <span itemprop="sku">MLI-00952</span>
</li>
<li>UPC Код: <span itemprop="gtin12">898220009527</span>
</li>
<li>Количество в Упаковке: 100 штук</li>
<li>
Размеры:
<div class="dimensions-popup-wrapper dimensions">
<span class="product-weight">
<span id="dimensions">11.4 x 6.1 x 6.1 cm </span>,
<span id="actual-weight">0.18 кг</span>
</span>
<div class="dimensions-units-popup dimensions">Переключиться на империальные единицы</div>
</div>
</li>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);