$re = '/.*?0?(1*)(?!.*\1[1])(.*)/m';
$str = '0
10001110
110000
1011101110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);