using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<system.serviceModel>)[\s\S]*?(?=<\/system.serviceModel>)";
string input = @"<system.serviceModel>Something in side the xml tag!</system.serviceModel>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}