#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\s)[0-9a-f]{2}(:[0-9a-f]{2}){5}\s+-?[[:digit:]]{2}"
Local $sString = " SSID BSSID RSSI CHANNEL" & @CRLF & _
" Something 12:34:56:78:98:ab -10 1" & @CRLF & _
"Something guest a2:34:56:78:98:ab -10 2" & @CRLF & _
" Network b2:34:56:78:98:ab -20 3 " & @CRLF & _
" Public network c2:34:56:78:98:ab -30 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")