$re = '~(?:\[)?{"aliases": .*?, (?:"birthday": (?:null))?(?:"birthday": "(.*?)")?, .*?}, "id": (\d+), "lp_name": .*?, "tag": "(.+?)", .*?}(?:\,\ )?(?:\]\})?~m';
$str = '{"meta": {"limit": 20, "next": "/api/v1/player/?apikey=Oke2O77ErEgcVgO9MlcK&order_by=tag&format=json&limit=20&offset=14120", "offset": 14100, "previous": "/api/v1/player/?apikey=Oke2O77ErEgcVgO9MlcK&order_by=tag&format=json&limit=20&offset=14080", "total_count": 23321}, "objects": [{"aliases": [], "birthday": null, "country": "PL", "current_rating": {"decay": 176, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9849680, "rating": -0.0243801604901709, "rating_vp": 0.0, "rating_vt": -0.00532036742913574, "rating_vz": 0.00532036742913574, "resource_uri": "/api/v1/rating/9849680/", "tot_vp": -0.0243801604901709, "tot_vt": -0.02970052791930664, "tot_vz": -0.019059793061035158}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -1.74867370252625, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 16623, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/16623/", "romanized_name": null, "sc2e_id": null, "tag": "Noel", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": null, "current_rating": {"decay": 170, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9833456, "rating": -0.0121706794793241, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9833456/", "tot_vp": -0.0121706794793241, "tot_vt": -0.0121706794793241, "tot_vz": -0.0121706794793241}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -1.75033384223174, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 17234, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "R", "resource_uri": "/api/v1/player/17234/", "romanized_name": null, "sc2e_id": null, "tag": "Noelchan", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["dawn"], "birthday": null, "country": "FR", "current_rating": {"decay": 284, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9842182, "rating": -0.00252570963605721, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9842182/", "tot_vp": -0.00252570963605721, "tot_vt": -0.00252570963605721, "tot_vz": -0.00252570963605721}, "current_teams": [], "dom_end": "/api/v1/period/38/", "dom_start": "/api/v1/period/37/", "dom_val": -1.04002179301258, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 5929, "lp_name": null, "mcnum": null, "name": "Yannis Rimani", "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/5929/", "romanized_name": null, "sc2e_id": null, "tag": "NoFaCe", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "RS", "current_rating": {"decay": 89, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9833568, "rating": -0.0627533541541087, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9833568/", "tot_vp": -0.0627533541541087, "tot_vt": -0.0627533541541087, "tot_vz": -0.0627533541541087}, "current_teams": [], "dom_end": "/api/v1/period/55/", "dom_start": "/api/v1/period/54/", "dom_val": -2.15506212678788, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 21553, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/21553/", "romanized_name": null, "sc2e_id": null, "tag": "NoFrx", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "PL", "current_rating": {"decay": 173, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9841022, "rating": -0.189179414238643, "rating_vp": 0.0117260728650132, "rating_vt": -0.0154219214934941, "rating_vz": 0.0036958486284809, "resource_uri": "/api/v1/rating/9841022/", "tot_vp": -0.1774533413736298, "tot_vt": -0.20460133573213712, "tot_vz": -0.1854835656101621}, "current_teams": [], "dom_end": "/api/v1/period/91/", "dom_start": "/api/v1/period/90/", "dom_val": -1.91347295627472, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 14644, "lp_name": null, "mcnum": 3, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/14644/", "romanized_name": null, "sc2e_id": null, "tag": "Noga", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": null, "current_rating": {"decay": 136, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9835275, "rating": -0.00223165747868316, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9835275/", "tot_vp": -0.00223165747868316, "tot_vt": -0.00223165747868316, "tot_vz": -0.00223165747868316}, "current_teams": [], "dom_end": "/api/v1/period/27/", "dom_start": "/api/v1/period/26/", "dom_val": -1.85902522506663, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 19637, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/19637/", "romanized_name": null, "sc2e_id": null, "tag": "nogain", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": "1993-02-07", "country": "IT", "current_rating": {"decay": 254, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9850702, "rating": 0.0912570393072352, "rating_vp": 0.0088978256537353, "rating_vt": 9.06255513078395e-05, "rating_vz": -0.00898845120504314, "resource_uri": "/api/v1/rating/9850702/", "tot_vp": 0.1001548649609705, "tot_vt": 0.09134766485854304, "tot_vz": 0.08226858810219205}, "current_teams": [], "dom_end": "/api/v1/period/54/", "dom_start": "/api/v1/period/53/", "dom_val": -1.13975403632189, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 5870, "lp_name": "", "mcnum": 2, "name": "Giuliano Gregori", "past_teams": [{"end": "2015-04-23", "id": 3436, "playing": true, "resource_uri": "", "start": null, "team": {"id": 259, "name": "True eSport", "resource_uri": "/api/v1/team/259/", "shortname": "TES"}}], "race": "Z", "resource_uri": "/api/v1/player/5870/", "romanized_name": null, "sc2e_id": null, "tag": "Nogard", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "CA", "current_rating": {"decay": 42, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9840937, "rating": -0.0183686222710952, "rating_vp": 0.00344237138928952, "rating_vt": -0.00344237138928952, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9840937/", "tot_vp": -0.014926250881805679, "tot_vt": -0.02181099366038472, "tot_vz": -0.0183686222710952}, "current_teams": [], "dom_end": "/api/v1/period/59/", "dom_start": "/api/v1/period/58/", "dom_val": -2.30184050045464, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 23494, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/23494/", "romanized_name": null, "sc2e_id": null, "tag": "Nogyo", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "KR", "current_rating": {"decay": 28, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9839194, "rating": 0.237959652214311, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9839194/", "tot_vp": 0.237959652214311, "tot_vt": 0.237959652214311, "tot_vz": 0.237959652214311}, "current_teams": [], "dom_end": "/api/v1/period/31/", "dom_start": "/api/v1/period/30/", "dom_val": -2.12659986501341, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 24726, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/24726/", "romanized_name": null, "sc2e_id": null, "tag": "NoinSung", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["n0ise"], "birthday": null, "country": "RO", "current_rating": {"decay": 317, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9831965, "rating": -0.135963137369375, "rating_vp": 0.0188619780140938, "rating_vt": -0.0190052650553335, "rating_vz": 0.000143287041239717, "resource_uri": "/api/v1/rating/9831965/", "tot_vp": -0.11710115935528119, "tot_vt": -0.1549684024247085, "tot_vz": -0.13581985032813526}, "current_teams": [], "dom_end": "/api/v1/period/64/", "dom_start": "/api/v1/period/63/", "dom_val": -1.02752973679455, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 3513, "lp_name": null, "mcnum": 2, "name": "Liviu Niculescu", "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/3513/", "romanized_name": null, "sc2e_id": null, "tag": "noise", "tlpd_db": 2, "tlpd_id": 3616, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "PL", "current_rating": {"decay": 170, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9844403, "rating": -0.103562427901856, "rating_vp": 0.0794302770731662, "rating_vt": -0.060401273960733, "rating_vz": -0.0190290031124332, "resource_uri": "/api/v1/rating/9844403/", "tot_vp": -0.024132150828689802, "tot_vt": -0.16396370186258902, "tot_vz": -0.12259143101428921}, "current_teams": [], "dom_end": "/api/v1/period/213/", "dom_start": "/api/v1/period/212/", "dom_val": -1.84172559065428, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 2193, "lp_name": null, "mcnum": 2, "name": "Åukasz Stankiewicz", "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/2193/", "romanized_name": null, "sc2e_id": null, "tag": "Noispaxen", "tlpd_db": 3, "tlpd_id": 3595, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "RO", "current_rating": {"decay": 208, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9834391, "rating": -0.0665154498130232, "rating_vp": 0.0, "rating_vt": -0.00551298910114763, "rating_vz": 0.00551298910114763, "resource_uri": "/api/v1/rating/9834391/", "tot_vp": -0.0665154498130232, "tot_vt": -0.07202843891417082, "tot_vz": -0.06100246071187557}, "current_teams": [], "dom_end": "/api/v1/period/33/", "dom_start": "/api/v1/period/32/", "dom_val": -1.64362239713795, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 13745, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/13745/", "romanized_name": null, "sc2e_id": null, "tag": "NoisyBoy", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": null, "current_rating": {"decay": 150, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9850808, "rating": -0.00828464177700495, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9850808/", "tot_vp": -0.00828464177700495, "tot_vt": -0.00828464177700495, "tot_vz": -0.00828464177700495}, "current_teams": [], "dom_end": "/api/v1/period/28/", "dom_start": "/api/v1/period/27/", "dom_val": -1.79971894932958, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 18928, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/18928/", "romanized_name": null, "sc2e_id": null, "tag": "Noitcereon", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": null, "current_rating": {"decay": 3, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9844030, "rating": -0.13641853585894, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9844030/", "tot_vp": -0.13641853585894, "tot_vt": -0.13641853585894, "tot_vz": -0.13641853585894}, "current_teams": [], "dom_end": "/api/v1/period/170/", "dom_start": "/api/v1/period/169/", "dom_val": -2.43250853010675, "form": {"P": [0, 0], "T": [0, 2], "Z": [0, 0], "total": [0, 2]}, "id": 19092, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/19092/", "romanized_name": null, "sc2e_id": null, "tag": "nok", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "US", "current_rating": {"decay": 373, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9841320, "rating": -0.0467309195015922, "rating_vp": 0.00781756694910287, "rating_vt": 0.0, "rating_vz": -0.00781756694910287, "resource_uri": "/api/v1/rating/9841320/", "tot_vp": -0.03891335255248933, "tot_vt": -0.0467309195015922, "tot_vz": -0.05454848645069507}, "current_teams": [], "dom_end": "/api/v1/period/26/", "dom_start": "/api/v1/period/25/", "dom_val": null, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 8390, "lp_name": null, "mcnum": null, "name": "Kevin Anderson", "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/8390/", "romanized_name": null, "sc2e_id": null, "tag": "Nokarot", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "FR", "current_rating": {"decay": 1, "dev": 0.140011347105564, "dev_vp": 0.139859896859909, "dev_vt": 0.14002857839344, "dev_vz": 0.16, "id": 9842415, "rating": -0.173475857194323, "rating_vp": -0.00132745639583776, "rating_vt": -0.000569829024791649, "rating_vz": 0.00189728542062941, "resource_uri": "/api/v1/rating/9842415/", "tot_vp": -0.17480331359016077, "tot_vt": -0.17404568621911468, "tot_vz": -0.1715785717736936}, "current_teams": [], "dom_end": "/api/v1/period/54/", "dom_start": "/api/v1/period/53/", "dom_val": -2.49917093034791, "form": {"P": [0, 2], "T": [0, 1], "Z": [0, 0], "total": [0, 3]}, "id": 24541, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/24541/", "romanized_name": null, "sc2e_id": null, "tag": "Nokota", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "RU", "current_rating": {"decay": 122, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9845791, "rating": -0.0262435805601763, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9845791/", "tot_vp": -0.0262435805601763, "tot_vt": -0.0262435805601763, "tot_vz": -0.0262435805601763}, "current_teams": [], "dom_end": "/api/v1/period/27/", "dom_start": "/api/v1/period/26/", "dom_val": -1.97472696148879, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 20945, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "R", "resource_uri": "/api/v1/player/20945/", "romanized_name": null, "sc2e_id": null, "tag": "nol", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["infamusson"], "birthday": null, "country": "DE", "current_rating": {"decay": 13, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9844717, "rating": -0.115470385974312, "rating_vp": 0.00858514478613128, "rating_vt": 0.00179273143279172, "rating_vz": -0.010377876218923, "resource_uri": "/api/v1/rating/9844717/", "tot_vp": -0.10688524118818073, "tot_vt": -0.11367765454152028, "tot_vz": -0.125848262193235}, "current_teams": [], "dom_end": "/api/v1/period/242/", "dom_start": "/api/v1/period/241/", "dom_val": -2.46252438949654, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 13029, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/13029/", "romanized_name": null, "sc2e_id": null, "tag": "NoLagsPlz", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["PSM", "EnjoyAMD"], "birthday": null, "country": "CZ", "current_rating": {"decay": 13, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9852041, "rating": 0.43131315783975, "rating_vp": 0.0654519447098798, "rating_vt": -0.115947906986093, "rating_vz": 0.0504959622762129, "resource_uri": "/api/v1/rating/9852041/", "tot_vp": 0.4967651025496298, "tot_vt": 0.31536525085365696, "tot_vz": 0.4818091201159629}, "current_teams": [{"end": null, "id": 7631, "playing": true, "resource_uri": "", "start": "2021-05-15", "team": {"id": 484, "name": "Project HIVE", "resource_uri": "/api/v1/team/484/", "shortname": "HIVE"}}], "dom_end": "/api/v1/period/308/", "dom_start": "/api/v1/period/307/", "dom_val": -1.91574084568248, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 5826, "lp_name": null, "mcnum": 2, "name": "Pavel Kubů", "past_teams": [{"end": "2017-05-13", "id": 7019, "playing": true, "resource_uri": "", "start": "2016-12-10", "team": {"id": 427, "name": "Passion Mercs", "resource_uri": "/api/v1/team/427/", "shortname": "PM"}}, {"end": null, "id": 4783, "playing": true, "resource_uri": "", "start": "2016-07-04", "team": {"id": 249, "name": "Invasion eSport", "resource_uri": "/api/v1/team/249/", "shortname": "Invasion"}}, {"end": "2018-05-14", "id": 5636, "playing": true, "resource_uri": "", "start": "2017-06-28", "team": {"id": 335, "name": "Houkago Tea Team", "resource_uri": "/api/v1/team/335/", "shortname": "HTT"}}, {"end": "2019-03-14", "id": 6313, "playing": true, "resource_uri": "", "start": "2018-05-14", "team": {"id": 386, "name": "Wolfs Lair E-Sports", "resource_uri": "/api/v1/team/386/", "shortname": "Wolven"}}], "race": "Z", "resource_uri": "/api/v1/player/5826/", "romanized_name": null, "sc2e_id": null, "tag": "NoLimit", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 684}, {"aliases": [], "birthday": null, "country": "NL", "current_rating": {"decay": 279, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9841331, "rating": -0.038709731781293, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9841331/", "tot_vp": -0.038709731781293, "tot_vt": -0.038709731781293, "tot_vz": -0.038709731781293}, "current_teams": [], "dom_end": "/api/v1/period/78/", "dom_start": "/api/v1/period/77/", "dom_val": -1.11427352016824, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 1090, "lp_name": null, "mcnum": 2, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/1090/", "romanized_name": null, "sc2e_id": null, "tag": "NOLot", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);