import re
regex = re.compile(r"[+]\d{2}?[-\s]?\d{5}?[-\s]?\d{5}|\(\d{3}\)\-\d{3}-\d{4}", flags=re.MULTILINE)
test_str = "+919823459330, +91 86690 43515, (333)-555-8869"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")