import re
regex = re.compile(r"(\(\d{2}\)\s)?\d+-?\d+", flags=re.MULTILINE)
test_str = ("Tefones:\n"
" - (14) 91313-64\n"
" - 3333-55521")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")