package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)NOT`)
var str = `Do you understand regex? OK or NOT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}