import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<classname>[\\w\\.]+)?(?:#(?<member>\\w+))$";
final String string = "Moo#withRecipientsWithDefaultName\n"
+ "#withRecipientsWithDefaultName\n"
+ "ClassName#member\n"
+ "ClassName\n"
+ "a.b..ClassName#member\n"
+ "a.b..ClassName";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}