// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\sLogonType="Owner""#).unwrap();
let string = "2019-04-01T00:14:59+02:00 Operation=\"\" OperationResult=\"\" LogonType=\"Owner\" MailboxOwnerUPN=\"\" MailboxOwnerSid=\"\" DestMailboxOwnerUPN=\"\" DestMailboxOwnerSid=\"\" DestMailboxGuid=\"\" CrossMailboxOperation=\"\" LogonUserDisplayName=\"\" LogonUserSid=\"\" SourceItems=\"\" SourceFolders=\"\" SourceItemIdsList=\"\" SourceItemSubjectsList=\"\" SourceItemAttachmentsList=\"\" SourceItemFolderPathNamesList=\"Inbox\" SourceFolderPathNamesList=\"\" ItemId=\"\" ItemSubject=\"\" ItemAttachments=\"\" DirtyProperties=\"\" OriginatingServer=\"\" MailboxGuid=\"\" MailboxResolvedOwnerName=\"\" LastAccessed=\"\" Identity=\"=\" IsValid=\"True\" ObjectState=\"New\"
2019-04-01T00:14:59+02:00 Operation=\"\" OperationResult=\"\" LogonType=\"Admin\" ExternalAccess=\"False\" DestFolderId=\"\" DestFolderPathName=\"\" FolderId=\"\" FolderPathName=\"\" ClientInfoString=\"Client=POP3/IMAP4;Protocol=IMAP4\" ClientIPAddress=\"\" ClientMachineName=\"\" ClientProcessName=\"\" ClientVersion=\"\" **InternalLogonType=\"Owner\"** MailboxOwnerUPN=\"\" MailboxOwnerSid=\"\" DestMailboxOwnerUPN=\"\" DestMailboxOwnerSid=\"\" DestMailboxGuid=\"\" CrossMailboxOperation=\"\" LogonUserDisplayName=\"\" LogonUserSid=\"\" SourceItems=\"\" SourceFolders=\"\" SourceItemIdsList=\" SourceItemSubjectsList=\"\" SourceItemAttachmentsList=\"\" SourceItemFolderPathNamesList=\"Inbox\" SourceFolderPathNamesList=\"\" ItemId=\"\" ItemSubject=\"\" ItemAttachments=\"\" DirtyProperties=\"\" OriginatingServer=\"\" MailboxGuid=\"\" MailboxResolvedOwnerName=\"\" LastAccessed=\"\" Identity=\"\" IsValid=\"True\" ObjectState=\"New\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}