#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[1-9])[0-9]*[02468]$"
Local $sString = "2" & @CRLF & _
"001234" & @CRLF & _
"00123400" & @CRLF & _
"002" & @CRLF & _
"20" & @CRLF & _
"16" & @CRLF & _
"" & @CRLF & _
"0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")