$re = '/^(?!0$)[a-z\d]+$/m';
$str = '0
00
12
22344
sometext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);