package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rs.*\d`)
var str = `rs1234-<b>C</b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}