#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{1,3}|[0-9]{1,3}\.[0-9]{1,3}|[0-9]{1,3}\.[0-9]{3}\.[0-9]{1,3})$"
Local $sString = "Valid" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"123.4" & @CRLF & _
"123.44" & @CRLF & _
"123.445" & @CRLF & _
"123.333.3" & @CRLF & _
"123.333.34" & @CRLF & _
"123.333.344" & @CRLF & _
"" & @CRLF & _
"Not Valid" & @CRLF & _
"" & @CRLF & _
"123.33.3" & @CRLF & _
"123.3.3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")