package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[not(*)]`)
var str = `<hello>
tester
</hello>
<!-- comment here -->
<soemthing>
blah
</something>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}