package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^a]|a([^b]|b([^c]|$)|$))*$`)
var str = `aabc`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}