package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.*(?<sim1>[\w\.]{4,}).*[\s]TZ.*(?<simno>[\w\.]).`)
var str = ` [Vodacom TZ (SIM 2)]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}