import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<command>add|do)(?=(?:.*?name\\/\"(?<taskName>.+?)\"))(?=(?:.*?startDate\\/\"(?<startDate>.+?)\")?)(?=(?:.*?endDate\\/\"(?<endDate>.+?)\")?)(?=(?:.*\\btags\\/(?<tags>\\w+(?:,\\w+)*)?\\b)?).*";
final String string = "add name/\"buy milk\" startDate/\"1110110000\" endDate/\"0812000000\" tags/buy,shopping\n"
+ "add name/\"buy milk\" startDate/\"today omg\" endDate/\"0812000000\" tags/buy,shopping\n"
+ "add name/\"buy milk\" startDate/\"today omg\" tags/buy,shopping endDate/\"0812000000\" \n"
+ "add name/\"buy milk\" tags/buy,shopping startDate/\"today omg\" endDate/\"0812000000\" \n"
+ "add name/\"buy milk\" endDate/\"0812000000\" tags/buy,shopping startDate/\"today omg\"\n"
+ "add name/\"buy milk\" endDate/\"0812000000\" startDate/\"today omg\"\n"
+ "add name/\"buy milk\" endDate/\"0812000000\" tags/buy,shopping \n"
+ "add endDate/\"0812000000\" tags/buy,shopping name/\"buy milk\"\n"
+ "add endDate/\"0812000000\" name/\"buy milk\" tags/buy,shopping \n"
+ "do name/\"buy milk\"\n\n\n\n\n"
+ "do \"buy milk\" on/0812 tag/buy,shopping at/1000\n"
+ "do tag/buy,shopping on/0812 at/1000 \"asdasd\"\n"
+ "do tag/buy,shopping on/0812 \"asdasd\" at/1000 \n"
+ "do at/1000 \"buy milk\"\n"
+ "do on/2100 \"buy milk\"\n"
+ "do at/1000 on/2100 \"buy milk\"\n"
+ "add at/1000 tag/omg \"buy milk\"\n"
+ "add on/2100 tag/omg \"buy milk\"\n\n"
+ "//floating task\n"
+ "do \"buy milk\"\n\n"
+ "on/2100 do \"buy milk\" at/1000 at/2100\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}