$re = '/page\/([0-9]*)\/tag/m';
$str = '<script defer="defer" type="text/javascript" class="teads" src="//a.teads.tv/page/123456/tag"></script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);