package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(W|w|L|l)(7|X|x)([a-zA-Z]{2,4}|[a-zA-Z]{3}it|[a-zA-Z]{3}IT)([0-9]{4})(.fortisbank.com.pl|)$`)
var str = `WXKRAIT0005.fortisbank.com.pl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}