$re = '/(?:\.|\+[^@]*)(?=.*@)/';
$str = 'test.email+alex@gmail.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;