import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w|data-]+)=[\"']?((?:.(?![\"']?\\s+(?:\\S+)=|\\s*\\/?[>\"']))+.)[\"']?";
final String string = "<img src=\"test.png?test=val\" data-double-dialot=\"hello\" />\n\n"
+ "<a href=test.html class=xyz>\n"
+ "<a href=\"test.html\" class=\"xyz\">\n"
+ "<a href='test.html' class=\"xyz\">\n"
+ "<script type=\"text/javascript\" defer async id=\"something\" onload=\"alert('hello');\"></script>\n"
+ "<img src=\"test.png\">\n"
+ "<img src=\"a test.png\">\n"
+ "<img src=test.png />\n"
+ "<img src=a test.png />\n"
+ "<img src=test.png >\n"
+ "<img src=a test.png >\n"
+ "<img src=test.png alt=crap >\n"
+ "<img src=a test.png alt=crap >\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}