import re
regex = re.compile(r"^([c][pP][eE]:\/[AHOaho]?(:[A-Za-z0-9._\-~%]*){0,6})$|^(cpe:2\.3:[aho*\-](:(((\?*|\*?)([a-zA-Z0-9\-._]|(\\[\\*?!\"#$%&'()+,/:;<=>@\[\]\^`{|}~]))+(\?*|\*?))|[*\-])){5}(:(([a-zA-Z]{2,3}(-([a-zA-Z]{2}|[0-9]{3}))?)|[*\-]))(:(((\?*|\*?)([a-zA-Z0-9\-._]|(\\[\\*?!\"#$%&'()+,/:;<=>@\[\]\^`{|}~]))+(\?*|\*?))|[*\-])){4})$", flags=re.MULTILINE)
test_str = ("PREFIXcpe:/o:redhat:rhel_aus:7.6::server\n"
"cpe:/o:redhat:rhel_aus:7.6::server::SUFFIX\n"
"PREFIXcpe:2.3:a:admin_management_xtended_project:admin_management_xtended:0.8:*:*:*:*:wordpress:*:*\n"
"cpe:2.3:a:admin_management_xtended_project:admin_management_xtended:0.8:*:*:*:*:wordpress:*:*\"\n"
"cpe:2.3:a:admin_management_xtended_project:admin_management_xtended:0.8:*:*:*:*:wordpress:*:**\n"
"cpe:2.3:a:cherokee-project:cherokee_web_server:*:*:*:*:*:*:*:*\n"
"cpe:/o:redhat:rhel_aus:7.6::server")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")